幻想森林

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 3451|回复: 1

[其他] 为ruby1.9.1装rails的经历

[复制链接]

136

主题

1751

帖子

548

积分

版主

Rank: 7Rank: 7Rank: 7

积分
548
发表于 2009-11-15 14:59:22 | 显示全部楼层 |阅读模式
    昨天折腾了一天时间。从上午开始,先的装的是ruby1.9.1,直接装rails 2.3.4,试运行,发现form_tag没法用,还以为是我自己写错了,查了又查,最后直接generate了一个scaffold,同样没办法用,终于确定是BUG。
    没办法,卸了ruby1.9.1,装ruby1.8.7 + rails 2.3.4,没有问题了。最后最倒霉的来了。RMagicK装不上。一旦inlucde MagicK就出错。RMagicK官方也没提供window下for1.8.7的安装包。没办法了,再卸。
    装ruby1.8.6+rails2.3.4,满以为RMagicK可以成功安装了。结果inlucde MagicK继续出错。好吧,我承认你很强大,我不用RMagick还不行么。换gd2,同样没法include,再换mini_magick,还是没法include。
   怒气槽,立刻MAX。全删了睡觉。  今天早上起来,牵了狗到处乱搜一通。
   还是先ruby 1.9.1,再来装rails,gem默认的站是不行了。直接从rails的官网装,gem install rails --source http://gems.rubyonrails.org 测试了一下,这回OK了。只是版本是2.3.3,可惜。再来装mini_magick,dll用的是ImageMagick官方最新的绿色包6.5.7-Q16-windows,也可以用了。最后是gem install mongrel --source http://gems.rubyinstaller.org装上这个http服务器。终于,想要的东西都不多都装上了。唉,玩开源工具真是费劲。
え~え~お!!!
回复

使用道具 举报

0

主题

3

帖子

29

积分

②入门

积分
29
发表于 2010-5-27 11:02:18 | 显示全部楼层
ruby1.8.6+rails1.2.3+mini_magick的人飘过……
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|幻想森林

GMT+8, 2024-7-14 16:25 , Processed in 0.015220 second(s), 20 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表